USN-274-2: MySQL vulnerability

15 May 2006

mysql-dfsg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

USN-274-1 fixed a logging bypass in the MySQL server. Unfortunately it was determined that the original update was not sufficient to completely fix the vulnerability, thus another update is necessary. We apologize for the inconvenience.

For reference, these are the details of the original USN:

A logging bypass was discovered in the MySQL query parser. A local attacker could exploit this by inserting NUL characters into query strings (even into comments), which would cause the query to be logged incompletely.

This only affects you if you enabled the ‘log’ parameter in the MySQL configuration.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
mysql-server
Ubuntu 5.04
mysql-server

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References