USN-280-1: X.org server vulnerability

4 May 2006

xorg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

The Render extension of the X.org server incorrectly calculated the size of a memory buffer, which led to a buffer overflow. A local attacker could exploit this to crash the X server or even execute arbitrary code with root privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
xserver-xorg
xserver-xorg-core
Ubuntu 5.04
xserver-xorg
xserver-xorg-core

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References