USN-2831-1: cups-filters vulnerability

7 December 2015

cups-filters vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 15.04
  • Ubuntu 14.04 LTS

Summary

cups-filters could be made to run programs as the lp user if it processed a specially crafted print job.

Software Description

  • cups-filters - OpenPrinting CUPS Filters

Details

Michal Kowalczyk discovered that the cups-filters foomatic-rip filter incorrectly stripped shell escape characters. A remote attacker could possibly use this issue to execute arbitrary code as the lp user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.10
cups-filters - 1.0.76-1ubuntu0.1
Ubuntu 15.04
cups-filters - 1.0.67-0ubuntu2.5
Ubuntu 14.04 LTS
cups-filters - 1.0.52-0ubuntu1.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References