USN-286-1: Dia vulnerabilities

24 May 2006

dia vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

Several format string vulnerabilities have been discovered in dia. By tricking a user into opening a specially crafted dia file, or a file with a specially crafted name, this could be exploited to execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
dia
dia-gnome
Ubuntu 5.04
dia
dia-gnome

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References