USN-2868-1: DHCP vulnerability

13 January 2016

isc-dhcp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 15.04
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

DHCP server, client, or relay could be made to crash if they received specially crafted network traffic.

Software Description

  • isc-dhcp - DHCP server and client

Details

Sebastian Poehn discovered that the DHCP server, client, and relay incorrectly handled certain malformed UDP packets. A remote attacker could use this issue to cause the DHCP server, client, or relay to stop responding, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.10
isc-dhcp-client - 4.3.1-5ubuntu3.1
isc-dhcp-relay - 4.3.1-5ubuntu3.1
isc-dhcp-server - 4.3.1-5ubuntu3.1
isc-dhcp-server-ldap - 4.3.1-5ubuntu3.1
Ubuntu 15.04
isc-dhcp-client - 4.3.1-5ubuntu2.3
isc-dhcp-relay - 4.3.1-5ubuntu2.3
isc-dhcp-server - 4.3.1-5ubuntu2.3
isc-dhcp-server-ldap - 4.3.1-5ubuntu2.3
Ubuntu 14.04 LTS
isc-dhcp-client - 4.2.4-7ubuntu12.4
isc-dhcp-relay - 4.2.4-7ubuntu12.4
isc-dhcp-server - 4.2.4-7ubuntu12.4
isc-dhcp-server-ldap - 4.2.4-7ubuntu12.4
Ubuntu 12.04 LTS
isc-dhcp-client - 4.1.ESV-R4-0ubuntu5.10
isc-dhcp-relay - 4.1.ESV-R4-0ubuntu5.10
isc-dhcp-server - 4.1.ESV-R4-0ubuntu5.10
isc-dhcp-server-ldap - 4.1.ESV-R4-0ubuntu5.10

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References