USN-287-1: Nagios vulnerability

29 May 2006

nagios vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

The nagios CGI scripts did not sufficiently check the validity of the HTTP Content-Length attribute. By sending a specially crafted HTTP request with an invalidly large Content-Length value to the Nagios server, a remote attacker could exploit this to execute arbitrary code with web server privileges.

Please note that the Apache 2 web server already checks for valid Content-Length values, so installations using Apache 2 (the only web server officially supported in Ubuntu) are not vulnerable to this flaw.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
nagios-common
Ubuntu 5.04
nagios-common

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References