USN-292-1: binutils vulnerability

9 June 2006

binutils vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

CVE-2006-2362

Jesus Olmos Gonzalez discovered a buffer overflow in the Tektronix Hex Format (TekHex) backend of the BFD library, such as used by the ‘strings’ utility. By tricking an user or automated system into processing a specially crafted file with ‘strings’ or a vulnerable third-party application using the BFD library, this could be exploited to crash the application, or possibly even execute arbitrary code with the privileges of the user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
binutils - 2.16.1cvs20060117-1ubuntu2.1
binutils-dev - 2.16.1cvs20060117-1ubuntu2.1
Ubuntu 5.10
binutils - 2.16.1-2ubuntu6.1
binutils-dev - 2.16.1-2ubuntu6.1
Ubuntu 5.04
binutils - 2.15-5ubuntu2.3
binutils-dev - 2.15-5ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References