USN-2926-1: OTR vulnerability

10 March 2016

libotr vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS

Summary

OTR could be made to crash or run programs if it received specially crafted network traffic.

Software Description

  • libotr - Off-the-Record Messaging library

Details

Markus Vervier discovered that OTR incorrectly handled large incoming messages. A remote attacker could use this issue to cause OTR to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04 LTS
libotr2 - 3.2.0-4ubuntu0.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart OTR applications to make all the necessary changes

References