USN-2957-1: Libtasn1 vulnerability

2 May 2016

libtasn1-3, libtasn1-6 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Libtasn1 could be made to hang if it processed specially crafted data.

Software Description

  • libtasn1-6 - Library to manage ASN.1 structures
  • libtasn1-3 - Library to manage ASN.1 structures

Details

Pascal Cuoq and Miod Vallat discovered that Libtasn1 incorrectly handled certain malformed DER certificates. A remote attacker could possibly use this issue to cause applications using Libtasn1 to hang, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.10
libtasn1-6 - 4.5-2ubuntu0.1
Ubuntu 14.04 LTS
libtasn1-6 - 3.4-3ubuntu0.4
Ubuntu 12.04 LTS
libtasn1-3 - 2.10-1ubuntu1.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References