USN-300-1: wv2 vulnerability

15 June 2006

wv2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

libwv2 did not sufficiently check the validity of its input. Certain invalid Word documents caused a buffer overflow. By tricking a user into opening a specially crafted Word file with an application that uses libwv2, this could be exploited to execute arbitrary code with the user’s privileges.

The only packaged application using this library is KWord.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
libwv2-1c2 - 0.2.2-5ubuntu0.1
libwv2-dev - 0.2.2-5ubuntu0.1
Ubuntu 5.10
libwv2-1c2 - 0.2.2-1ubuntu2.1
libwv2-dev - 0.2.2-1ubuntu2.1
Ubuntu 5.04
libwv2-1 - 0.2.2-1ubuntu1.1
libwv2-dev - 0.2.2-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart KWord to effect the necessary changes.

References