USN-3026-1: libimobiledevice vulnerability

5 July 2016

libimobiledevice vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS
  • Ubuntu 15.10
  • Ubuntu 14.04 LTS

Summary

libimobiledevice would allow unintended access to devices over the network.

Software Description

  • libimobiledevice - Library for communicating with iPhone and iPod Touch devices

Details

It was discovered that libimobiledevice incorrectly handled socket permissions. A remote attacker could use this issue to access services on iOS devices, contrary to expectations.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
libimobiledevice6 - 1.2.0+dfsg-3~ubuntu0.2
Ubuntu 15.10
libimobiledevice4 - 1.1.6+dfsg-3.1ubuntu0.1
Ubuntu 14.04 LTS
libimobiledevice4 - 1.1.5+git20140313.bafe6a9e-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References