USN-3069-1: Eye of GNOME vulnerability

25 August 2016

eog vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Eye of GNOME could be made to crash or run programs as your login if it opened a specially crafted image.

Software Description

  • eog - Eye of GNOME graphics viewer program

Details

It was discovered that Eye of GNOME incorrectly handled certain invalid UTF-8 strings. If a user were tricked into opening a specially-crafted image, a remote attacker could use this issue to cause Eye of GNOME to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
eog - 3.18.2-1ubuntu2.1
Ubuntu 14.04 LTS
eog - 3.10.2-0ubuntu5.2
Ubuntu 12.04 LTS
eog - 3.4.2-0ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References