USN-315-1: libmms, xine-lib vulnerabilities

13 July 2006

libmms, xine-lib vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

Matthias Hopf discovered several buffer overflows in libmms. By tricking a user into opening a specially crafted remote multimedia stream with an application using libmms, a remote attacker could exploit this to execute arbitrary code with the user’s privileges.

The Xine library contains an embedded copy of libmms, and thus needs the same security update.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
libxine-main1 - 1.1.1+ubuntu2-7.2
Ubuntu 5.10
libmms0 - 0.1-0ubuntu1.2
libxine1c2 - 1.0.1-1ubuntu10.4
Ubuntu 5.04
libxine1 - 1.0-1ubuntu3.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.