USN-322-1: Konqueror vulnerability

25 July 2006

kdelibs vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

A Denial of Service vulnerability has been reported in the replaceChild() method in KDE’s DOM handler. A malicious remote web page could exploit this to cause Konqueror to crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
kdelibs - 4:3.5.2-0ubuntu18.1
Ubuntu 5.10
kdelibs - 4:3.4.3-0ubuntu2.1
Ubuntu 5.04
kdelibs - 4:3.4.0-0ubuntu3.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References