USN-325-1: ruby1.8 vulnerability

28 July 2006

ruby1.8 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

The alias function, certain directory operations, and regular expressions did not correctly implement safe levels. Depending on the application these flaws might allow attackers to bypass safe level restrictions and perform unintended operations.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
libruby1.8 - 1.8.4-1ubuntu1.1
ruby1.8 - 1.8.4-1ubuntu1.1
Ubuntu 5.10
libruby1.8 - 1.8.2-9ubuntu1.2
ruby1.8 - 1.8.2-9ubuntu1.2
Ubuntu 5.04
libruby1.8 - 1.8.1+1.8.2pre4-1ubuntu0.4
ruby1.8 - 1.8.1+1.8.2pre4-1ubuntu0.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References