USN-3341-1: Systemd vulnerability

27 June 2017

systemd vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.10


systemd-resolved could be made to crash or run programs if it received a specially crafted DNS response.

Software Description

  • systemd - system and service manager


An out-of-bounds write was discovered in systemd-resolved when handling specially crafted DNS responses. A remote attacker could potentially exploit this to cause a denial of service (daemon crash) or execute arbitrary code. (CVE-2017-9445)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.04
systemd - 232-21ubuntu5
Ubuntu 16.10
systemd - 231-9ubuntu5

To update your system, please follow these instructions:

In general, a standard system update will make all the necessary changes.