USN-3397-1: strongSwan vulnerability

21 August 2017

strongswan vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

strongSwan could be made to crash or hang if it received specially crafted network traffic.

Software Description

  • strongswan - IPsec VPN solution

Details

It was discovered that strongSwan incorrectly handled verifying specific RSA signatures. A remote attacker could use this issue to cause strongSwan to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.04
libstrongswan - 5.5.1-1ubuntu3.2
strongswan - 5.5.1-1ubuntu3.2
Ubuntu 16.04 LTS
libstrongswan - 5.3.5-1ubuntu3.4
strongswan - 5.3.5-1ubuntu3.4
Ubuntu 14.04 LTS
libstrongswan - 5.1.2-0ubuntu2.7
strongswan - 5.1.2-0ubuntu2.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References