USN-346-2: Fixed linux-restricted-modules-2.6.15 for previous Linux kernel update

15 September 2006

linux-restricted-modules-2.6.15 regression fix

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS

Software Description

Details

USN-346-1 provided an updated Linux kernel to fix several security vulnerabilities. Unfortunately the update broke the binary ‘nvidia’ driver from linux-restricted-modules. This update corrects this problem. We apologize for the inconvenience.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
avm-fritz-firmware-2.6.15-26 - 2.6.15.11-4
avm-fritz-kernel-source - 2.6.15.11-4
fglrx-control - 2.6.15.11-4
fglrx-kernel-source - 2.6.15.11-4
linux-restricted-modules-2.6.15-26-386 - 2.6.15.11-4
linux-restricted-modules-2.6.15-26-686 - 2.6.15.11-4
linux-restricted-modules-2.6.15-26-amd64-generic - 2.6.15.11-4
linux-restricted-modules-2.6.15-26-amd64-k8 - 2.6.15.11-4
linux-restricted-modules-2.6.15-26-amd64-xeon - 2.6.15.11-4
nic-restricted-firmware-2.6.15-26-386-di - 2.6.15.11-4
nic-restricted-firmware-2.6.15-26-amd64-generic-di - 2.6.15.11-4
nic-restricted-modules-2.6.15-26-386-di - 2.6.15.11-4
nic-restricted-modules-2.6.15-26-amd64-generic-di - 2.6.15.11-4
nvidia-glx - 2.6.15.11-4
nvidia-glx-dev - 2.6.15.11-4
nvidia-glx-legacy - 2.6.15.11-4
nvidia-glx-legacy-dev - 2.6.15.11-4
nvidia-kernel-source - 2.6.15.11-4
nvidia-legacy-kernel-source - 2.6.15.11-4
xorg-driver-fglrx - 2.6.15.11-4
xorg-driver-fglrx-dev - 2.6.15.11-4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to reboot your computer to effect the necessary changes.