USN-3515-1: Ruby vulnerability

4 January 2018

ruby1.9.1, ruby2.0, ruby2.3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS


Ruby could be made to execute arbitrary commands if opened a specially crafted file.

Software Description

  • ruby2.3 - Interpreter of object-oriented scripting language Ruby
  • ruby1.9.1 - Object-oriented scripting language
  • ruby2.0 - Object-oriented scripting language


It was discovered that Ruby allows FTP command injection. An attacker could use this to cause arbitrary command execution.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
libruby2.3 - 2.3.3-1ubuntu1.1
ruby2.3 - 2.3.3-1ubuntu1.1
Ubuntu 17.04
libruby2.3 - 2.3.3-1ubuntu0.3
ruby2.3 - 2.3.3-1ubuntu0.3
Ubuntu 16.04 LTS
libruby2.3 - 2.3.1-2~16.04.4
ruby2.3 - 2.3.1-2~16.04.4
Ubuntu 14.04 LTS
libruby1.9.1 -
libruby2.0 -
ruby1.9.1 -
ruby1.9.3 -
ruby2.0 -

To update your system, please follow these instructions:

In general, a standard system update will make all the necessary changes.