USN-3563-1: Mailman vulnerability

8 February 2018

mailman vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Mailman could be made to run arbitrary code.

Software Description

  • mailman - Powerful, web-based mailing list manager

Details

It was discovered that Mailman incorrectly handled certain web scripts. An attacker could possibly use this to inject arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
mailman - 1:2.1.23-1ubuntu0.2
Ubuntu 16.04 LTS
mailman - 1:2.1.20-1ubuntu0.3
Ubuntu 14.04 LTS
mailman - 1:2.1.16-2ubuntu0.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References