USN-3603-1: Paramiko vulnerability

20 March 2018

paramiko vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Paramiko could be made to run programs if it received specially crafted network traffic.

Software Description

  • paramiko - Python SSH2 library

Details

Matthijs Kooijman discovered that Paramiko’s SSH server implementation did not properly require authentication before processing requests. An unauthenticated remote attacker could possibly use this to execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
python-paramiko - 2.0.0-1ubuntu0.1
python3-paramiko - 2.0.0-1ubuntu0.1
Ubuntu 16.04 LTS
python-paramiko - 1.16.0-1ubuntu0.1
python3-paramiko - 1.16.0-1ubuntu0.1
Ubuntu 14.04 LTS
python-paramiko - 1.10.1-1git1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart any applications using Paramiko’s server implementation to make all the necessary changes.

References