USN-3605-1: Sharutils vulnerability

22 March 2018

sharutils vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Sharutils could be made to execute arbitrary code if it opened a specially crafted file.

Software Description

  • sharutils - shar, unshar, uuencode, uudecode

Details

It was discovered that Sharutils incorrectly handled certain files. An attacker could possibly use this to execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
sharutils - 1:4.15.2-2ubuntu0.1
Ubuntu 16.04 LTS
sharutils - 1:4.15.2-1ubuntu0.1
Ubuntu 14.04 LTS
sharutils - 1:4.14-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References