USN-3610-1: ICU vulnerability

28 March 2018

icu vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

ICU could be made to crash if it received specially crafted input.

Software Description

  • icu - International Components for Unicode library

Details

It was discovered that ICU incorrectly handled certain calendars. If an application using ICU processed crafted data, a remote attacker could possibly cause it to crash, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
libicu57 - 57.1-6ubuntu0.3
Ubuntu 16.04 LTS
libicu55 - 55.1-7ubuntu0.4
Ubuntu 14.04 LTS
libicu52 - 52.1-3ubuntu0.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References