USN-3661-1: Batik vulnerability

29 May 2018

batik vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

Batik could be made to expose sensitive information if it received a specially crafted XML.

Software Description

  • batik - SVG Library

Details

It was discovered that Batik incorrectly handled certain XML. An attacker could possibly use this to expose sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
libbatik-java - 1.7.ubuntu-8ubuntu2.14.04.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References