USN-3684-1: Perl vulnerability

13 June 2018

perl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Perl could be made to overwrite arbitrary files if it received a specially crafted archive file.

Software Description

  • perl - Practical Extraction and Report Language

Details

It was discovered that Perl incorrectly handled certain archive files. An attacker could possibly use this to overwrite arbitrary files.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
perl - 5.26.1-6ubuntu0.1
Ubuntu 17.10
perl - 5.26.0-8ubuntu1.2
Ubuntu 16.04 LTS
perl - 5.22.1-9ubuntu0.5
Ubuntu 14.04 LTS
perl - 5.18.2-2ubuntu1.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References