USN-3707-1: NTP vulnerabilities

9 July 2018

ntp vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Several security issues were fixed in NTP.

Software Description

  • ntp - Network Time Protocol daemon and utility programs

Details

Yihan Lian discovered that NTP incorrectly handled certain malformed mode 6 packets. A remote attacker could possibly use this issue to cause ntpd to crash, resulting in a denial of service. This issue only affected Ubuntu 17.10 and Ubuntu 18.04 LTS. (CVE-2018-7182)

Michael Macnair discovered that NTP incorrectly handled certain responses. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2018-7183)

Miroslav Lichvar discovered that NTP incorrectly handled certain zero-origin timestamps. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 17.10 and Ubuntu 18.04 LTS. (CVE-2018-7184)

Miroslav Lichvar discovered that NTP incorrectly handled certain zero-origin timestamps. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2018-7185)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
ntp - 1:4.2.8p10+dfsg-5ubuntu7.1
Ubuntu 17.10
ntp - 1:4.2.8p10+dfsg-5ubuntu3.3
Ubuntu 16.04 LTS
ntp - 1:4.2.8p4+dfsg-3ubuntu5.9
Ubuntu 14.04 LTS
ntp - 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References