USN-3726-1: Django vulnerability

1 August 2018

python-django vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS

Summary

Django could be used as an open redirect.

Software Description

  • python-django - High-level Python web development framework

Details

Andreas Hug discovered that Django contained an open redirect in CommonMiddleware. A remote attacker could possibly use this issue to perform phishing attacks.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
python-django - 1:1.11.11-1ubuntu1.1
python3-django - 1:1.11.11-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References