USN-3745-1: wpa_supplicant and hostapd vulnerability

20 August 2018

wpa vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

wpa_supplicant and hostapd could be made to expose sensitive information if it received a crafted message.

Software Description

  • wpa - client support for WPA and WPA2

Details

It was discovered that wpa_supplicant and hostapd incorrectly handled certain messages. An attacker could possibly use this to access sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
hostapd - 2:2.6-15ubuntu2.1
wpasupplicant - 2:2.6-15ubuntu2.1
Ubuntu 16.04 LTS
hostapd - 2.4-0ubuntu6.3
wpasupplicant - 2.4-0ubuntu6.3
Ubuntu 14.04 LTS
hostapd - 2.1-0ubuntu1.6
wpasupplicant - 2.1-0ubuntu1.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References