USN-3750-1: Pango vulnerability

22 August 2018

pango1.0 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS

Summary

Pango could be made to crash if it opened a specially crafted file.

Software Description

  • pango1.0 - Layout and rendering of internationalized text - gir bindings

Details

Jeffrey M. discovered that Pango incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
gir1.2-pango-1.0 - 1.40.14-1ubuntu0.1
libpango-1.0-0 - 1.40.14-1ubuntu0.1
libpango1.0-0 - 1.40.14-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart your session to make all the necessary changes.

References