USN-376-2: imlib2 regression fix

6 November 2006

imlib2 regression fix

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

USN-376-1 provided an update to imlib2 to fix several security vulnerabilities. Unfortunately the update broke JPG file handling in certain situations. This update corrects this problem. We apologize for the inconvenience.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libimlib2 - 1.2.1-2ubuntu1.2
Ubuntu 6.06 LTS
libimlib2 - 1.2.1-2ubuntu0.2
Ubuntu 5.10
libimlib2 - 1.2.0-2.2ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References