USN-3767-1: GLib vulnerabilities

19 September 2018

glib2.0 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Several security issues were fixed in GLib.

Software Description

  • glib2.0 - GLib Input, Output and Streaming Library (fam module)

Details

It was discovered that GLib incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2018-16428)

It was discovered that GLib incorrectly handled certain files. An attacker could possibly use this issue to access sensitive information. (CVE-2018-16429)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
libglib2.0-0 - 2.56.2-0ubuntu0.18.04.2
libglib2.0-bin - 2.56.2-0ubuntu0.18.04.2
libglib2.0-dev - 2.56.2-0ubuntu0.18.04.2
Ubuntu 16.04 LTS
libglib2.0-0 - 2.48.2-0ubuntu4.1
libglib2.0-bin - 2.48.2-0ubuntu4.1
libglib2.0-dev - 2.48.2-0ubuntu4.1
Ubuntu 14.04 LTS
libglib2.0-0 - 2.40.2-0ubuntu1.1
libglib2.0-bin - 2.40.2-0ubuntu1.1
libglib2.0-dev - 2.40.2-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References