USN-379-1: texinfo vulnerability

9 November 2006

texinfo vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

Miloslav Trmac discovered a buffer overflow in texinfo’s index processor. If a user is tricked into processing a .texi file with texindex, this could lead to arbitrary code execution with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
texinfo - 4.8.dfsg.1-1ubuntu0.1
Ubuntu 6.06 LTS
texinfo - 4.8-4ubuntu0.1
Ubuntu 5.10
texinfo - 4.7-2.2ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References