USN-3796-1: Paramiko vulnerability

17 October 2018

paramiko vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Paramiko could allow unintended access to network services.

Software Description

  • paramiko - Python SSH2 library

Details

Daniel Hoffman discovered that Paramiko incorrectly handled authentication when being used as a server. A remote attacker could use this issue to bypass authentication without any credentials.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
python-paramiko - 2.0.0-1ubuntu1.1
python3-paramiko - 2.0.0-1ubuntu1.1
Ubuntu 16.04 LTS
python-paramiko - 1.16.0-1ubuntu0.2
python3-paramiko - 1.16.0-1ubuntu0.2
Ubuntu 14.04 LTS
python-paramiko - 1.10.1-1git1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References