USN-381-1: Firefox vulnerabilities

21 November 2006

firefox vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

USN-351-1 fixed a flaw in the verification of PKCS certificate signatures. Ulrich Kuehn discovered a variant of the original attack which the original fix did not cover. (CVE-2006-5462)

Various flaws have been reported that allow an attacker to execute arbitrary code with user privileges by tricking the user into opening a malicious web page containing JavaScript. (CVE-2006-5463, CVE-2006-5464, CVE-2006-5747, CVE-2006-5748)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06 LTS
firefox - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
firefox-dev - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
libnspr-dev - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
libnspr4 - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
libnss-dev - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
libnss3 - 1.5.dfsg+1.5.0.8-0ubuntu0.6.06
Ubuntu 5.10
firefox - 1.5.dfsg+1.5.0.8-0ubuntu0.5.10
firefox-dev - 1.5.dfsg+1.5.0.8-0ubuntu0.5.10

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart Firefox to effect the necessary changes.

References