USN-3892-1: GDM vulnerability

20 February 2019

gdm3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.10
  • Ubuntu 18.04 LTS

Summary

GDM could give unauthorized access to a different user.

Software Description

  • gdm3 - GNOME Display Manager

Details

Burghard Britzke discovered that GDM incorrectly handled certain configurations. An attacker could possibly use this issue to get unauthorized access to a different user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
gdm3 - 3.30.1-1ubuntu5.1
Ubuntu 18.04 LTS
gdm3 - 3.28.3-0ubuntu18.04.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References