USN-392-1: xine-lib vulnerability

4 December 2006

xine-lib vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

A buffer overflow was discovered in the Real Media input plugin in xine-lib. If a user were tricked into loading a specially crafted stream from a malicious server, the attacker could execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libxine1 - 1.1.2+repacked1-0ubuntu3.2
Ubuntu 6.06 LTS
libxine-main1 - 1.1.1+ubuntu2-7.5
Ubuntu 5.10
libxine1c2 - 1.0.1-1ubuntu10.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References