USN-394-1: Ruby vulnerability

8 December 2006

ruby1.8 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

An error was found in Ruby’s CGI library that did not correctly quote the boundary of multipart MIME requests. Using a crafted HTTP request, a remote user could cause a denial of service, where Ruby CGI applications would end up in a loop, monopolizing a CPU.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libruby1.8 - 1.8.4-5ubuntu1.2
Ubuntu 6.06 LTS
libruby1.8 - 1.8.4-1ubuntu1.3
Ubuntu 5.10
libruby1.8 - 1.8.2-9ubuntu1.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References