USN-3954-1: FreeRADIUS vulnerabilities

24 April 2019

freeradius vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS

Summary

FreeRADIUS could be made to bypass authentication if it received a specially crafted input.

Software Description

  • freeradius - high-performance and highly configurable RADIUS server

Details

It was discovered that FreeRADIUS incorrectly handled certain inputs. An attacker could possibly use this issue to bypass authentication. (CVE-2019-11234, CVE-2019-11235)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
freeradius - 3.0.17+dfsg-1ubuntu2.1
Ubuntu 18.10
freeradius - 3.0.16+dfsg-3ubuntu1.1
Ubuntu 18.04 LTS
freeradius - 3.0.16+dfsg-1ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References