USN-3963-1: Memcached vulnerability

1 May 2019

memcached vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS

Summary

Memcached could be made to crash if it received specially crafted network traffic.

Software Description

  • memcached - high-performance memory object caching system

Details

It was discovered that Memcached incorrectly handled certain lru command messages. A remote attacker could possibly use this issue to cause Memcached to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
memcached - 1.5.10-0ubuntu1.19.04.1
Ubuntu 18.10
memcached - 1.5.10-0ubuntu1.18.10.1
Ubuntu 18.04 LTS
memcached - 1.5.6-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References