USN-397-1: mono vulnerability

20 December 2006

mono vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS

Software Description

Details

Jose Ramon Palanco discovered that the mono System.Web class did not consistently verify local file paths. As a result, the source code for mono web applications could be retrieved remotely, possibly leading to further compromise via the application’s source.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
libmono-system-web1.0-cil - 1.1.17.1-1ubuntu7.1
libmono-system-web2.0-cil - 1.1.17.1-1ubuntu7.1
Ubuntu 6.06 LTS
mono-classlib-1.0 - 1.1.13.6-0ubuntu3.2
mono-classlib-2.0 - 1.1.13.6-0ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart any mono web applications to effect the necessary changes.

References