USN-3988-1: MediaInfo vulnerabilities

16 May 2019

libmediainfo vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS

Summary

MediaInfo could be made to crash if it opened a specially crafted file.

Software Description

  • libmediainfo - library reading metadata from media files

Details

It was discovered that MediaInfo contained multiple security issues when handling certain multimedia files. If a user were tricked into opening a crafted multimedia file, an attacker could cause MediaInfo to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
libmediainfo0v5 - 18.12-1ubuntu0.1
Ubuntu 18.10
libmediainfo0v5 - 18.03.1-1ubuntu0.1
Ubuntu 18.04 LTS
libmediainfo0v5 - 17.12-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References