USN-40-1: PHP vulnerabilities

17 December 2004

php4 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 4.10

Software Description

Details

Stefan Esser reported several buffer overflows in PHP’s variable unserializing handling. These could allow an attacker to execute arbitrary code on the server with the PHP interpreter’s privileges by sending specially crafted input strings (form data, cookie values, and similar).

Additionally, Ilia Alshanetsky discovered a buffer overflow in the exif_read_data() function. Attackers could execute arbitrary code on the server by sending a JPEG image with a very long “sectionname” value to PHP applications that support image uploads.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 4.10
libapache2-mod-php4
php4
php4-cgi

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References