USN-4015-2: DBus vulnerability

12 June 2019

dbus vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

DBus could allow unintended access to services.

Software Description

  • dbus - simple interprocess messaging system

Details

USN-4015-1 fixed a vulnerability in DBus. This update provides the corresponding update for Ubuntu 12.04 ESM and Ubuntu 14.04 ESM.

Original advisory details:

Joe Vennix discovered that DBus incorrectly handled DBUS_COOKIE_SHA1 authentication. A local attacker could possibly use this issue to bypass authentication and connect to DBus servers with elevated privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 ESM
dbus - 1.6.18-0ubuntu4.5+esm1
libdbus-1-3 - 1.6.18-0ubuntu4.5+esm1
Ubuntu 12.04 ESM
dbus - 1.4.18-1ubuntu1.9
libdbus-1-3 - 1.4.18-1ubuntu1.9

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References