USN-4039-1: CImg vulnerabilities

26 June 2019

CImg vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.10
  • Ubuntu 18.04 LTS

Summary

Several security issues were fixed in CImg.

Software Description

  • cimg - C++ template image processing toolkit

Details

It was discovered that allocation failures could occur in CImg when loading crafted bmp images. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-7587)

It was discovered that a heap-based buffer over-read existed in CImg when loading crafted bmp images. An attacker could possibly use this issue to execute arbitrary code. (CVE-2018-7588)

It was discovered that a double free existed in CImg when loading crafted bmp images. An attacker could possibly use this issue to execute arbitrary code. (CVE-2018-7589)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
cimg-dev - 1.7.9+dfsg-2ubuntu0.18.10.1
Ubuntu 18.04 LTS
cimg-dev - 1.7.9+dfsg-2ubuntu0.18.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References