USN-4055-1: flightcrew vulnerabilities

15 July 2019

flightcrew vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in FlightCrew.

Software Description

  • flightcrew - C++ epub validator and plugin for Sigil

Details

Mike Salvatore discovered that FlightCrew improperly handled certain malformed EPUB files. An attacker could potentially use this vulnerability to cause a denial of service. (CVE-2019-13032)

Mike Salvatore discovered that FlightCrew mishandled certain malformed EPUB files. An attacker could use this vulnerability to write arbitrary files to the filesystem. (CVE-2019-13241)

Mike Salvatore discovered that the version of Zipios included in FlightCrew mishandled certain malformed ZIP files. An attacker could use this vulnerability to cause a denial of service or consume system resources. (CVE-2019-13453)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
flightcrew - 0.7.2+dfsg-13ubuntu0.19.04.1
libflightcrew0v5 - 0.7.2+dfsg-13ubuntu0.19.04.1
Ubuntu 18.10
flightcrew - 0.7.2+dfsg-12ubuntu0.1
libflightcrew0v5 - 0.7.2+dfsg-12ubuntu0.1
Ubuntu 18.04 LTS
flightcrew - 0.7.2+dfsg-10ubuntu0.1
libflightcrew0v5 - 0.7.2+dfsg-10ubuntu0.1
Ubuntu 16.04 LTS
flightcrew - 0.7.2+dfsg-6ubuntu0.1
libflightcrew0v5 - 0.7.2+dfsg-6ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References