USN-4057-1: Zipios vulnerability

15 July 2019

Zipios vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Zipios could be made to crash or consume system resources if it received specially crafted input.

Software Description

  • zipios++ - small C++ library for reading zip files (development)

Details

Mike Salvatore discovered that Zipios mishandled certain malformed ZIP files. An attacker could use this vulnerability to cause a denial of service or consume system resources. (CVE-2019-13453)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
libzipios++0v5 - 0.1.5.9+cvs.2007.04.28-10ubuntu0.19.04.1
Ubuntu 18.10
libzipios++0v5 - 0.1.5.9+cvs.2007.04.28-10ubuntu0.18.10.1
Ubuntu 18.04 LTS
libzipios++0v5 - 0.1.5.9+cvs.2007.04.28-10ubuntu0.18.04.1
Ubuntu 16.04 LTS
libzipios++0v5 - 0.1.5.9+cvs.2007.04.28-5.2ubuntu0.16.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References