USN-4079-1: SoX vulnerabilities

30 July 2019

sox vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS

Summary

SoX could be made to crash if it received a specially crafted MP3 file.

Software Description

  • sox - Swiss army knife of sound processing

Details

It was discovered that SoX incorrectly handled certain MP3 files. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-8354, CVE-2019-8355, CVE-2019-8356, CVE-2019-8357)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS
libsox2 - 14.4.1-5+deb8u4ubuntu0.1
sox - 14.4.1-5+deb8u4ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References