USN-4089-1: Rack vulnerability

7 August 2019

ruby-rack vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Rack could allow cross-site scripting (XSS) attacks.

Software Description

  • ruby-rack - modular Ruby webserver interface

Details

It was discovered that Rack incorrectly handled carefully crafted requests. A remote attacker could use this issue to execute a cross-site scripting (XSS) attack.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
ruby-rack - 1.6.4-4ubuntu0.1
Ubuntu 16.04 LTS
ruby-rack - 1.6.4-3ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References