USN-409-1: ksirc vulnerability

16 January 2007

kdenetwork vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 6.10
  • Ubuntu 6.06 LTS
  • Ubuntu 5.10

Software Description

Details

Federico L. Bossi Bonin discovered a Denial of Service vulnerability in ksirc. By sending a special response packet, a malicious IRC server could crash ksirc.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
ksirc - 4:3.5.5-0ubuntu1.1
Ubuntu 6.06 LTS
ksirc - 4:3.5.2-0ubuntu6.3
Ubuntu 5.10
ksirc - 4:3.4.3-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References