USN-4101-1: Firefox vulnerability

16 August 2019

firefox vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

A local attacker could obtain saved passwords.

Software Description

  • firefox - Mozilla Open Source web browser

Details

It was discovered that passwords could be copied to the clipboard from the "Saved Logins" dialog without entering the master password, even when a master password has been set. A local attacker could potentially exploit this to obtain saved passwords.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
firefox - 68.0.2+build1-0ubuntu0.19.04.1
Ubuntu 18.04 LTS
firefox - 68.0.2+build1-0ubuntu0.18.04.1
Ubuntu 16.04 LTS
firefox - 68.0.2+build1-0ubuntu0.16.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox to make all the necessary changes.

References